I messed up my setup of Python and other packages. I get the following error, now, when I attempt to install beeware. Neither Beeware nor Toga are working.

$ pip install --upgrade --pre beeware 
Collecting beeware
  Using cached https://files.pythonhosted.org/packages/34/10/7e2afc95a9290e827b83b634b982dfd969f908f6dbbfa6ecd153532c7863/beeware-0.1.1-py2.py3-none-any.whl
Collecting toga>=0.3.0.dev2 (from beeware)
  Using cached https://files.pythonhosted.org/packages/04/73/3ded37ce19d9657be425fffd1ee76d7cde26395baab17c01548db0230927/toga-0.3.0.dev11-py3-none-any.whl
Requirement already satisfied, skipping upgrade: briefcase in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from beeware) (0.2.8)
Collecting toga-gtk==0.3.0.dev11; sys_platform == "linux" (from toga>=0.3.0.dev2->beeware)
  Using cached https://files.pythonhosted.org/packages/58/03/fd1b50d3e694191119e828e1455309e265cb80a17ea3a1f39eb0b411dc26/toga_gtk-0.3.0.dev11-py3-none-any.whl
Requirement already satisfied, skipping upgrade: cookiecutter>=1.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from briefcase->beeware) (1.6.0)
Requirement already satisfied, skipping upgrade: voc>=0.1.1 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from briefcase->beeware) (0.1.6)
Requirement already satisfied, skipping upgrade: pip>=18.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from briefcase->beeware) (18.1)
Requirement already satisfied, skipping upgrade: requests<3.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from briefcase->beeware) (2.21.0)
Requirement already satisfied, skipping upgrade: urllib3<1.24 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from briefcase->beeware) (1.23)
Requirement already satisfied, skipping upgrade: boto3>=1.4.4 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from briefcase->beeware) (1.9.78)
Requirement already satisfied, skipping upgrade: setuptools>=40.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from briefcase->beeware) (40.6.3)
Collecting pygobject>=3.14.0 (from toga-gtk==0.3.0.dev11; sys_platform == "linux"->toga>=0.3.0.dev2->beeware)
  Using cached https://files.pythonhosted.org/packages/59/9c/57ec6ad0d57c5f621b4f3c2256a7087d27a81b8c5a92237ac2f3fe66406c/PyGObject-3.31.2.dev0.tar.gz
  Installing build dependencies ... done
  Requested pygobject>=3.14.0 from https://files.pythonhosted.org/packages/59/9c/57ec6ad0d57c5f621b4f3c2256a7087d27a81b8c5a92237ac2f3fe66406c/PyGObject-3.31.2.dev0.tar.gz#sha256=e6b2dbd2de84bdc2d4e867300f2f43ee36dcd6b7d2a7fec115404e321c1eb852 (from toga-gtk==0.3.0.dev11; sys_platform == "linux"->toga>=0.3.0.dev2->beeware), but installing version 3.31.2.dev0
Requirement already satisfied, skipping upgrade: gbulb>=0.5.3 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from toga-gtk==0.3.0.dev11; sys_platform == "linux"->toga>=0.3.0.dev2->beeware) (0.6.1)
Requirement already satisfied, skipping upgrade: pycairo>=1.17.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from toga-gtk==0.3.0.dev11; sys_platform == "linux"->toga>=0.3.0.dev2->beeware) (1.18.0)
Requirement already satisfied, skipping upgrade: toga-core==0.3.0.dev11 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from toga-gtk==0.3.0.dev11; sys_platform == "linux"->toga>=0.3.0.dev2->beeware) (0.3.0.dev11)
Requirement already satisfied, skipping upgrade: jinja2>=2.7 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from cookiecutter>=1.0->briefcase->beeware) (2.10)
Requirement already satisfied, skipping upgrade: future>=0.15.2 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from cookiecutter>=1.0->briefcase->beeware) (0.17.1)
Requirement already satisfied, skipping upgrade: whichcraft>=0.4.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from cookiecutter>=1.0->briefcase->beeware) (0.5.2)
Requirement already satisfied, skipping upgrade: poyo>=0.1.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from cookiecutter>=1.0->briefcase->beeware) (0.4.2)
Requirement already satisfied, skipping upgrade: click>=5.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from cookiecutter>=1.0->briefcase->beeware) (7.0)
Requirement already satisfied, skipping upgrade: binaryornot>=0.2.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from cookiecutter>=1.0->briefcase->beeware) (0.4.4)
Requirement already satisfied, skipping upgrade: jinja2-time>=0.1.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from cookiecutter>=1.0->briefcase->beeware) (0.2.0)
Requirement already satisfied, skipping upgrade: certifi>=2017.4.17 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from requests<3.0->briefcase->beeware) (2018.11.29)
Requirement already satisfied, skipping upgrade: chardet<3.1.0,>=3.0.2 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from requests<3.0->briefcase->beeware) (3.0.4)
Requirement already satisfied, skipping upgrade: idna<2.9,>=2.5 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from requests<3.0->briefcase->beeware) (2.8)
Requirement already satisfied, skipping upgrade: s3transfer<0.2.0,>=0.1.10 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from boto3>=1.4.4->briefcase->beeware) (0.1.13)
Requirement already satisfied, skipping upgrade: botocore<1.13.0,>=1.12.78 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from boto3>=1.4.4->briefcase->beeware) (1.12.78)
Requirement already satisfied, skipping upgrade: jmespath<1.0.0,>=0.7.1 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from boto3>=1.4.4->briefcase->beeware) (0.9.3)
Requirement already satisfied, skipping upgrade: travertino>=0.1.0 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from toga-core==0.3.0.dev11->toga-gtk==0.3.0.dev11; sys_platform == "linux"->toga>=0.3.0.dev2->beeware) (0.1.2)
Requirement already satisfied, skipping upgrade: MarkupSafe>=0.23 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from jinja2>=2.7->cookiecutter>=1.0->briefcase->beeware) (1.1.0)
Requirement already satisfied, skipping upgrade: arrow in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from jinja2-time>=0.1.0->cookiecutter>=1.0->briefcase->beeware) (0.13.0)
Requirement already satisfied, skipping upgrade: docutils>=0.10 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from botocore<1.13.0,>=1.12.78->boto3>=1.4.4->briefcase->beeware) (0.14)
Requirement already satisfied, skipping upgrade: python-dateutil<3.0.0,>=2.1; python_version >= "2.7" in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from botocore<1.13.0,>=1.12.78->boto3>=1.4.4->briefcase->beeware) (2.7.5)
Requirement already satisfied, skipping upgrade: six>=1.5 in ./anaconda3/envs/BeeWare/lib/python3.7/site-packages (from python-dateutil<3.0.0,>=2.1; python_version >= "2.7"->botocore<1.13.0,>=1.12.78->boto3>=1.4.4->briefcase->beeware) (1.12.0)
Building wheels for collected packages: pygobject
  Running setup.py bdist_wheel for pygobject ... error
  Complete output from command /home/brandon/anaconda3/envs/BeeWare/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-r59b_a2i/pygobject/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/pip-wheel-gmg9b7wz --python-tag cp37:
  running bdist_wheel
  running build
  running build_py
  creating build
  creating build/lib.linux-x86_64-3.7
  creating build/lib.linux-x86_64-3.7/pygtkcompat
  copying pygtkcompat/generictreemodel.py -> build/lib.linux-x86_64-3.7/pygtkcompat
  copying pygtkcompat/pygtkcompat.py -> build/lib.linux-x86_64-3.7/pygtkcompat
  copying pygtkcompat/__init__.py -> build/lib.linux-x86_64-3.7/pygtkcompat
  creating build/lib.linux-x86_64-3.7/gi
  copying gi/_compat.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/_gtktemplate.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/module.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/_error.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/types.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/_ossighelper.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/pygtkcompat.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/_option.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/docstring.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/importer.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/_propertyhelper.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/_constants.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/_signalhelper.py -> build/lib.linux-x86_64-3.7/gi
  copying gi/__init__.py -> build/lib.linux-x86_64-3.7/gi
  creating build/lib.linux-x86_64-3.7/gi/repository
  copying gi/repository/__init__.py -> build/lib.linux-x86_64-3.7/gi/repository
  creating build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/GLib.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/keysyms.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/Gtk.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/GIMarshallingTests.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/Gio.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/GdkPixbuf.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/Gdk.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/Pango.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/__init__.py -> build/lib.linux-x86_64-3.7/gi/overrides
  copying gi/overrides/GObject.py -> build/lib.linux-x86_64-3.7/gi/overrides
  running build_ext
  pycairo: new API
  Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1283, in <module>
      main()
    File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1278, in main
      zip_safe=False,
    File "/tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/setuptools/__init__.py", line 143, in setup
      return distutils.core.setup(**attrs)
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/core.py", line 148, in setup
      dist.run_commands()
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 966, in run_commands
      self.run_command(cmd)
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 985, in run_command
      cmd_obj.run()
    File "/tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/wheel/bdist_wheel.py", line 188, in run
      self.run_command('build')
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/cmd.py", line 313, in run_command
      self.distribution.run_command(command)
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 985, in run_command
      cmd_obj.run()
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/command/build.py", line 135, in run
      self.run_command(cmd_name)
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/cmd.py", line 313, in run_command
      self.distribution.run_command(command)
    File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 985, in run_command
      cmd_obj.run()
    File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1115, in run
      self._setup_extensions()
    File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1110, in _setup_extensions
      add_pycairo(gi_cairo_ext)
    File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1093, in add_pycairo
      ext.include_dirs += [get_pycairo_include_dir()]
    File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 915, in get_pycairo_include_dir
      include_dir = find_path(find_new_api())
    File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 860, in find_new_api
      import cairo
    File "/tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/cairo/__init__.py", line 1, in <module>
      from ._cairo import *  # noqa: F401,F403
  ImportError: /tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/cairo/_cairo.cpython-37m-x86_64-linux-gnu.so: undefined symbol: cairo_tee_surface_index
  
  ----------------------------------------
  Failed building wheel for pygobject
  Running setup.py clean for pygobject
Failed to build pygobject
Installing collected packages: pygobject, toga-gtk, toga, beeware
  Running setup.py install for pygobject ... error
    Complete output from command /home/brandon/anaconda3/envs/BeeWare/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-r59b_a2i/pygobject/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-_fmf3r51/install-record.txt --single-version-externally-managed --compile:
    running install
    running build
    running build_py
    creating build
    creating build/lib.linux-x86_64-3.7
    creating build/lib.linux-x86_64-3.7/pygtkcompat
    copying pygtkcompat/generictreemodel.py -> build/lib.linux-x86_64-3.7/pygtkcompat
    copying pygtkcompat/pygtkcompat.py -> build/lib.linux-x86_64-3.7/pygtkcompat
    copying pygtkcompat/__init__.py -> build/lib.linux-x86_64-3.7/pygtkcompat
    creating build/lib.linux-x86_64-3.7/gi
    copying gi/_compat.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/_gtktemplate.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/module.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/_error.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/types.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/_ossighelper.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/pygtkcompat.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/_option.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/docstring.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/importer.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/_propertyhelper.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/_constants.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/_signalhelper.py -> build/lib.linux-x86_64-3.7/gi
    copying gi/__init__.py -> build/lib.linux-x86_64-3.7/gi
    creating build/lib.linux-x86_64-3.7/gi/repository
    copying gi/repository/__init__.py -> build/lib.linux-x86_64-3.7/gi/repository
    creating build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/GLib.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/keysyms.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/Gtk.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/GIMarshallingTests.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/Gio.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/GdkPixbuf.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/Gdk.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/Pango.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/__init__.py -> build/lib.linux-x86_64-3.7/gi/overrides
    copying gi/overrides/GObject.py -> build/lib.linux-x86_64-3.7/gi/overrides
    running build_ext
    pycairo: new API
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1283, in <module>
        main()
      File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1278, in main
        zip_safe=False,
      File "/tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/setuptools/__init__.py", line 143, in setup
        return distutils.core.setup(**attrs)
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/core.py", line 148, in setup
        dist.run_commands()
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 966, in run_commands
        self.run_command(cmd)
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 985, in run_command
        cmd_obj.run()
      File "/tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/setuptools/command/install.py", line 61, in run
        return orig.install.run(self)
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/command/install.py", line 545, in run
        self.run_command('build')
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 985, in run_command
        cmd_obj.run()
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/command/build.py", line 135, in run
        self.run_command(cmd_name)
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "/home/brandon/anaconda3/envs/BeeWare/lib/python3.7/distutils/dist.py", line 985, in run_command
        cmd_obj.run()
      File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1115, in run
        self._setup_extensions()
      File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1110, in _setup_extensions
        add_pycairo(gi_cairo_ext)
      File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 1093, in add_pycairo
        ext.include_dirs += [get_pycairo_include_dir()]
      File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 915, in get_pycairo_include_dir
        include_dir = find_path(find_new_api())
      File "/tmp/pip-install-r59b_a2i/pygobject/setup.py", line 860, in find_new_api
        import cairo
      File "/tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/cairo/__init__.py", line 1, in <module>
        from ._cairo import *  # noqa: F401,F403
    ImportError: /tmp/pip-build-env-jzi58_uk/lib/python3.7/site-packages/cairo/_cairo.cpython-37m-x86_64-linux-gnu.so: undefined symbol: cairo_tee_surface_index
    
    ----------------------------------------
Command "/home/brandon/anaconda3/envs/BeeWare/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-r59b_a2i/pygobject/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-_fmf3r51/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-install-r59b_a2i/pygobject/